Eine neue, größere Festplatte in eine Buffalo Linkstation Pro einbauen


By rakekniven - Posted on 23 Februar 2009

Habe mir Anfang 2007 eine Buffalo Linkstation Pro mit 320GB gekauft. Das war damals schon eine beachtliche Größe und das Preis/Leistungsverhältnis war ok. Mittlerweile sind die Platten sehr groß und günstig geworden. Man bekommt ein GB schon für unter 9 Cent. So kaufte ich mir eine "grüne" Festplatte mit 1TB (braucht nur 7W) und machte mich an die Planung. Bei meiner Linkstation ist das Betriebssystem ebenfalls auf der Festplatte drauf und somit kann man nicht einfach eine neue Platte einbauen, diese formatieren und fertig. Es gibt zwei Generationen von Linkstations, also vorher genau nachschauen. Ich fand eine gute Anleitung unter buffalo.nas-central.org. Die folgenden Schritte waren nötig, dann lief alles wie gewünscht:

  1. Daten der alten Festplatte sichern
  2. Die Linkstation öffnen (Anleitung) und die Festplatte ausbauen.
  3. Die alte und neue Platte an einen PC anschliessen.
  4. Klonen der alten auf die neue Platte mit einem Werkzeug wie z.B. Acronis True Image
  5. Die neue Festplatte in die Linkstation einbauen
  6. Eine Firmware aufspielen oder eigene Partitionen auf der Box erstellen,
  7. Hinweis- zum Flashen bzw. Partitionieren der Festplatte müssen Sie in den Debug-Modus der LSUpdater.exe wechseln und die Option "rebuild partition table" auswählen.

    Frage: Wie wechsel ich in den Debug-Modus?
    Antwort: Starten Sie die *updater.exe und klicken im nun erscheinenden Fenster mit rechter Maustaste auf die Titelleiste und wählen Sie “Debug…”

  8. Linkstation wieder passend einrichten, bei mir gingen alle Einstellungen verloren.
  9. Daten aufspielen
  10. fertig

Danach wird die Linkstation LS-320GL im NAS-Navigator2 von Buffalo als LS-1000GL angezeigt. Für ca. 85 € eine verdreifachung des Speichers, was will man mehr :-)


NASNavigator2 von Buffalo zeigt die neue Größe

Update: 2012-03-29

Der folgende Screenshot zeigt eine eingebaute 2TB-Platte.

Links

Hallo, Danke für die super Anleitung zum Tausch der HDD in der Linkstation.

Bin auch gerade am Tauschen.... HDD wird gerade geklont von 250 GB auf 1TB.

Müsstest du die neue HDD eigentlich noch mal formatieren ?
... es werden doch jetzt nur 250 GB geklont.
Ich kopiere mit HDD Clone.

Nochmal Danke für die Anleitung, ich glaube sonst hätte ich mich nicht ran getraut....

Gruß, Michael

Hi Michael,

man kann beim Klonen auch gleich den restlichen Platz zuweisen.

Zumindest geht das bei Acronis True Image.

Gruß

Hallo, ich habe ebenfalls eine LinkStation. Vor einiger Zeit habe ich die Festplatte ausgebaut und für einen anderen Zweck "vergewaltigt". Leider habe ich kein Image von der Platte gezogen. Jetzt habe ich eine neue Platte gekauft und eingebaut. Natürlich läuft die LinkStation jetzt nicht. Ich komm auch nicht übers Netzwerk drauf. Wie kann ich die neue Platte zum Laufen bekommen? Gruß Silvio...

Schau mal im Wiki unter http://buffalo.nas-central.org/wiki/Main_Page nach.

Vielleicht findest Du dort eine Lösung, ich selbst habe spontan keine Parat.

Ich nochmal, erstmal danke für den Link, der hat mir leider noch nicht viel geholfen. Ich habe heut auch mit dem Support von Buffalo telefoniert. Die meinten wenn ich kein Image von der Platte gezogen habe, habe ich keine Chance die Linkstation wiedern zum Laufen zu bekommen. Jetzt ist mir eine Idee gekommen und ich hoffe es kann mir jemand dabei helfen. Ich benötige ein Image einer Baugleichen Linkstation (natürlich ohne private Daten) also ähnlich Auslieferungszustand und mit eingestellter IP-Adresse. Dieses Image kann ich dann an einem PC auf die neue Platte ziehen. Dann sollte ich ich die Linkstation nach Einbau der Platte wieder nutzen können, oder? Gruß Silvio...

Ja, das ist die Lösung.

Ich kann leider mit keinem Image dienen.

Habe gerade gesehen das http://buffalo.nas-central.org/ auch ein Forum bietet. Dort gibt es auch einen deutschsprachigen Bereiche. Dort mal das Problem posten und vielleicht kann jemand helfen.

Link: http://forum.buffalo.nas-central.org/viewforum.php?f=14

Gruß

Hallo, du brauchst kein Image! Es Reicht wenn du TFTP benutzt. "Buffalo bietet auf ihrer Webseite TFTP in Kombination mit dem Kernel und der initrd für ihre NAS an. initrd (sinngemäß übersetzt "Ausgangspartition im Arbeitsspeicher") ist ein temporäres Dateisystem, das vom Linux-Kernel während des Bootvorgangs verwendet wird" http://www.discountnetz.com/buffalo-linkstation/fehlerbehebung/92-buffal... gruß

Hi!
Erstmal vielen Dank für die klasse Anleitung.
Funktioniert soweit auch sehr gut.
Habe die 500 GB Platte auf 1 TB HD geklont.
Danach wie inder Anletung beschrieben eingebaut, funktioniert.
Es werden aber nur die 500 GB erkannt.
Danach habe ich versucht die Platte zu flashen,
wie in der Anleitung und im You Tube Video erklärt.
Bekam div.Fehlermeldungen.
Aus Verzweifelung die FW 1.5 aufgespielt.
Danach hat sich das Ding formatiert.
Alle geklonten Daten weg.
Was mache ich falsch???

Habe mit Conzilla geklont.
Wie kann ich den unpartitionierten Bereich freigeben, daß die Platte
mit der richtigen Kapazität erkannt wird?

Wäre echt sehr dankbar, für Deine Hilfe!!!

Gruß
Felix

Nichts, denn das ist so.

Bei diesem Modell liegt das OS (Firmware) mit auf der Platte. Das Klonen ist also notwendig, damit das OS auf der neuen Platte landet. Um den restlichen Speicherplatz zu nutzen ist eine Neuformatierung notwendig. Dabei gehen alle Daten verloren.
Der Punkt 9 meiner kleinen Anleitung lautet "Daten aufspielen". Das ist damit gemeint.

Gruß

Nachtrag:
Oder man weisst den neuen, freien Bereich gleich beim Klonen zu. Das geht mit Acronis True Image, andere Tools kenne ich leider nicht so gut.

Danke für die schnelle Antwort.
Nachdem ich die geklonte Platte in die Linkstation eingebaut
habe, wird sie wieder mit der gleichen Kapazität wie die Originalplatte erkannt.
Komme ab diesem Punkt einfach nicht weiter.

Formatierung über Linkstation bringt leider nichts.-gleiches Ergebnis.

Beim Aufspielen der FW bekomme ich folg. Fehlermeldung
"Couldn´t confirm a response from LSGLBF4 Please check a network adress of both PC and Linksation
Please disable Firewall--(hatte ich natürlich vorher gemacht, genauso wie das Anti Vir. Prog)- Updating aborted!!!
Beim 2. Versuch gings dann.
Nas Navigator zeigt an das die Platte unformatiert ist.
Formatierung über Linkstation fehlgeschlagen, auch nach div Neustarts von Pc und Linksation kein Erfolg

Update mit der Einstellung Rebuild Partition table durchgeführt.
Formatierung wurde kurz vor Ende abgebrochen.
Linksation blinkt rot.-keine Verbindung mehr möglich( da alle Daten (Betriebssystem) vermutlich gelöscht sind,- so wie gestern)

Mit acronics 2010 versucht die partition beim klonen direkt freizugeben.
Kann keine Einstellung finden, die das möglich macht???!!!
Bei der Option "manuell" kann ich den freien Bereich zwar erkennen
aber nicht freigeben, daß ich eine 931GB oder ähnliches erreiche.

Vielleicht kannst Du einem armen Irren mit einer idiotensicheren Anleitung helfen???

Vielen Dank

Felix

puh, da habe ich jetzt aber auch keine gute Idee mehr für Dich, sorry.

Habe mit Acronis 11 als Bootmedium gearbeitet und da konnte ich den Platz zuweisen.
Da ich meine Linkstation im Produktivbetrieb habe, kann ich da auch nicht nachschauen.

Das die Formatierung abbricht, ist kein gutes Zeichen.
Ist die Platte ok?
Wie groß war die LS vorher? 320GB?

Gruß

Halllo!

Es ist eine Linkstation 500GB
Ich denke das die Platte ok ist, da Sie unter Ubuntu , oder XP
keine Fehler aufweist oder mucken macht.
Auch der geklonte Originalteil lässst sich ohne weiteres über
die Linksation formatieren.

Das interessante ist , das ich die freie Parition finde,
Sie auch formatieren kann, aber wenn ich die beiden Partitionen
zusammenlegen will ( Über Acronis Director Suite 10)bekomme ich
folg. Nachricht:"Der maximal mögliche Speicherplatz ist 465GB.

Über True Image 10 Kann ich Unterpartitionen erstellen, aber keine
Zuammenführung.

Ich nehme an das irgendetwas diese Zusammenlegung der Partitionen mit Absicht blockiert.

Ich habe auf Fw.15 upgedatet.
Viellleicht mit einem Downgrade versuchen.
Aber wo bekomme ich die alte Version 1.03 her??
Oder gibt es vielleicht eine modifizierte FW?

Übrigens nach dem Formatierungsabruch, geht das Gerät in den EM - Modus.????
Bin ich denn der einzige bei dem das nicht hinhaut?

Bin für jede Hilfe dankbar.

Kaufen kann jeder, jetzt ist sportlicher Ehrgeiz gefragt :-)

Gruß und Danke

Felix

Wenn das Zusammenlegen von Partitionen nicht klappt, dann ist vielleicht ein löschen und neu anlegen (über kompletten Platz) möglich?

Das mit dem Ehrgeiz finde ich gut!

Ich muss Dich aufgrund mangelnder Hilfestellung aber auf http://buffalo.nas-central.org/wiki/Main_Page verweisen. Hier findest Du jede Menge Infos und auch ein Forum.

Gruß

ES IST VOLLBRACHT!!!!!!!

Ich habe als erstes die Firmware downgegradet.
Da ich immer die Conectionfehler hatte, war Ich es leid
und habe die Linkstation direkt ( ohne Switch) an den PC angeschlossen.
Habe auch das Original Lankabel verwendet.
Zusäzlich das Internetnetzwerk deaktiviert.
Danach die Anweisung wie beschrieben durchgeführt
und siehe da, alles prima.
--wenn die Linkstation , jetzt nicht chinesische Schriftzeichen gehabt hätte :-)

Danach mit Fw. 1.15 upgedatet, gleiches Problem.

Im Internet gegooglet und siehe da mit zwei drei Klicks , Sprache auf
Deutsch umgestellt.
Es geht also doch.

Und nun die unverschämte Frage bis zur welchen Größe erkennt
die Linksation die Festplatte?
Spiele mit dem Gedanken eine 2TB Platte einzubauen!
Noch ein Tip:Für alle die keine Vollvesion von Acronis True Image haben.
Habe die Festplatte mit Clonzilla geklont.
Ist ein kostenfreies Linux- Programm das über CD gebootet wird.
Mit ein bißchen Erfahrung einfach zu bedienen aber vor allem sehr schnell!
Um 500GB (ohne zusätzliche Daten )zu klonen brauchte es ca. 25 min

Glückwunsch!

Das mit den japanischen Zeichen hatte ich, aber leider nicht in die Anleitung geschrieben.
Hast Du noch den Google-Link, der Dir weitergeholfen hat?

Größe der Festplatte:
Das bin ich auch schon öfter gefragt worden, aber ich weiss es nicht.
Auch googeln hat mir da nicht weiter geholfen.
Lass es uns wissen, wenn Du es ausprobiert hast

Link zu Clonzilla: http://clonezilla.org/

Meine Empfehlung ist aber Parted Magic. Boot-CD mit gparted (Partitionierungstool), Clonzilla und vielen weiteren nützlichen Werkzeugen.

Hi!
Erstmal der Link zu deutscher Schrift.

http://www.tomshardware.de/foren/239915-10-buffalo-laufwerk

Natürlich heißt das tool clonezilla und nicht conzilla.
War da etwa übereifrig....

Denke werde den Umbau auf 2 TB wagen.
Allerdings habe ich noch eine Linkstation Live (LS-CHL C4D)
mit einem TB.
Wäre dort ein Umbau auf 2TB möglich??
Gibt es Anleitungen oder wichtige Progs.
Habe im Internet gegooglet, bin aber nicht fündig geworden.
Das einzige was ich rausbekommen habe, das es sie in der 2TB - Version zu kaufen gibt.
Also müsste der Umbau technisch möglich sein.
Die Frage ist, liegt das OS ebenfalls auf der Platte und wie gehe ich nach dem klonen der alten Platte weiter vor.

Werde mir mal die updates dazu runterladen und mir diese anschauen

Gruß

Feix

Ja !- Genau diese.

Hallo,

super Anleitung - eine Stelle hat mich nur aus der Bahn geworfen. Der Debug Modus. Ich habe auf einer anderen Seite folgende Anleitung gefunden, vielleicht willst Du das noch beifügen.

Starten Sie nun die *updater.exe und klicken im nun erscheinenden Fenster mit rechter Maustaste auf die Titelleiste und waehlen Sie “Debug…”

Danach habe ich ewig gesucht...

Liebe Grüße, Tobias

Hinzugefügt. Danke für das Feedback.

Cheers

prima Anleitung.

das Problem die Partition im nachhinein zu Erweitern lässt sich prima mit gparted (linux) lösen.

Einfach geht es indem man von einer CD bootet.

hier gibts das ISO: http://gparted.sourceforge.net/livecd.php

Guter Tipp.

Ich empfehle jedoch Parted Magic. Diese Boot-CD beinhaltet gparted und startet auf fast allen Rechnern, egal ob alt oder neu.

Link: http://partedmagic.com

Jo mit Parted Magic habe ich es auch hinbekommen. Meine alte Terastation Pro erstellte mir auf den neu eingebauten 2TB HDs nur die ursprüngliche Größe von 500GB und der Rest blieb frei. Also habe ich die Partition gelöscht und in voller Größe erstellt und im XFS-Datisystem formatiert. Danach habe ich die Partition eingehängt. Nachdem ich die HD wieder in der Terastation eingebaut habe wurde ihre Grösse zwar nicht erkannt, ABER, nachdem ich sie in der Terastation erneut formatierte, wurde die HD auch mit 2,0TB anstatt mit 500GB formatiert, was durch das "Einhängen" kommt. Jetzt habe ich aber das gleiche Problem mit der Größe des Raids. Wenn ich ein Raid5 einrichte, geschieht dieses mit der alten Größe also 1,4GB anstatt ungefähr 6GB die bei 4 x 2TB rauskommen müssten. Ich habe schon die neueste Firmware drauf, hat jemand eine Idee die zu überlisten

Gruß Baltar

Hi,

danke für die super Anleitung auf deutsch. Ich habe eine LS-GL Version 1 mit der originalen Festplatte von 250GB drin. Die reicht nicht mehr aus und deswegen möchte ich eben eine neue Platte einsetzten. Ist es egal für welches Model man sich da entscheidet? Aktuelle Platten haben ja z.B. ein Puffer von 64MB und die ursprünglich eingebaute nur von 8MB. Stellen solche Unterschiede ein Problem da? Welche 2TB Platte hattest du eingebaut? Hast du gute Erfahrung im letzten halben Jahr mit dieser gemacht?

 

Guten Start in die Woche!

 

Tobi

Bisher habe ich folgende Modelle verbaut:

  • WD10EACS-00D6B0 1TB
  • Samsung SpindPoint F4EG 2TB

Bis heute läuft alles klaglos ohne irgendein Problem. Wie groß der Puffer bei den Modellen ist, weiß ich nicht auswendig. Kann man ja nachschlagen.

Ein 3TB-Modell habe ich noch nicht ausprobiert.

Vielleicht kann jemand anderes dazu etwas sagen?

Gruß

Hi,

hab mir jetzt auch mal die Samsung SpindPoint F4EG 2TB bestellt. Wird zwar jetzt von Seagate produziert...aber mal gucken obs gut klappt.

Ich werde berichten

Gruß

Tobi

Hi,

habs heute gemacht. Hat auch alles 1A geklappt. Hab jetzt auch ne 2TB Linkstation. Momentan kriege ich die noch nicht ins Active Directory meines MS Server 2003 wieder eingebunden, aber der Einbau war problemlos. Danke für die Erklärung!!!

 

Tobi

Hat das mit der AD noch geklappt?

Bei mir hats heute leider nicht nach der Anleitung oben geklappt, die LS gab nur Blinken und piepsen von sich. Ich hatte mit Acronis True Image Home geklont und konnte auch nicht dir Partitionsgrößen verändern. 

Habe dann mit gparted die Partitionen auf der neuen Platte genauso eingeteilt wie auf der alten, wobei natürlich dann die 6. partition maximalgröße hatte. Anschließend mit CloneZilla die einzelnen Partitionen nacheinander geklont.

Platte wieder eingebaut und hat ohne Probleme funktioniert.

Jetzt läuft eine WD10EARS mit 1 TB Speicher.

 

Gruß,

Lagombes

Super.

Wie immer gilt: Viele Wege führen nach Rom :-)

Danke für deine Tipps. Die Erweiterung auf 1 TB habe ich, vor ein paar Jahren, ebenfalls gemacht. Da sich die Preise wieder beruhigt haben werde ich ebenfalls auf 2 TB umrüsten

Ich habe eine linkstation und habe mir zwei 1tb festplatten gekauft nur die linkstation findet die nich muss ich die formantieren ntfs oder wie auch immer? 

Mfg freeyze

Welches Modell hast Du genau? Meine Linkstations haben nur ein Laufwerk.

Bei der einfachen Linkstation liegt das OS (ein Linux) auf der Platte. Ein formatieren ist daher nicht möglich.

ntfs gibt es nur in der Windows-Welt.

Hallo,

die Anleitung würde ich gerne auf meine (LS-V) anwenden, da ich gerne auf eine 24/7-Platte mit mehr Speicher wechseln möchte. Jedoch traue ich mich nun doch nicht so recht, da es hier ja um ein anderes Modell geht. Die neue Platte liegt allerdings schon hier...

(Vl. hat ja wer Erfahrung gesammelt und online finde ich nichts speziell für die LS-V Serie. Lediglich ein schlechtes Video wie man die HDD ausbaut.)

So habe mir nun die Zeit genommen....

Acronis (2011) ging bei mir nicht. Sowohl im Win als auch mit der CD. Da war die HDD ausgegraut und nicht auswählbar.

So hat es bei mir funktioniert:

1. Mit EASEus von der "Super Recovrey-Linux" ein Clone gemacht.

2. Die Partition der Disk 1 war nicht modifizierbar, auch nicht mit Gpart. Produzierte Fehlermeldung also habe ich diese Partition (xfs mit 9xx GB) gelöscht. Dort eine neue zu erstellen ging dann auch nicht.

3. Die LS-V in gab Fehlermedungen im Navigator und LSUpdater... Also Hardware-Reset. ("Function" gedrückt halten während man die LS einschaltet, die Funktion-LED blinkt schnell, dann noch mal Funktion drücken.)

4. Die Linkstation in der Weboberfläsche formatieren Lassen.

5. Die Ordner von Hand einrichten und die Einstellungen der LS alle wieder machen.

6. Kein FW-Update gemacht, da die 1.64 ja schon drauf war und die LS soweit ich es sagen kann funktioniert wie sie soll, mit der größeren 24/7er HDD. (NAS Navigator meldet nun auch keine Fehler mehr...)

Nun noch die Daten wieder drauf, welche ich natürlich vor dem Ganzen gesichert hatte...

Schön das ich dabei festgesltt habe, das meine >neu gekaufte< LS schon geöffnet worden war. Habe ich dann an den Aufklebern und anderen Spuren bemerkt. ARGH!!!

Zur Frage nach den 3 TB - das geht nicht da das FS nur Partitionen bis 2 TB kann - Festplatte wird dann mit 2047 GB angezeigt

Hast Du das ausprobiert?

Das FS ist doch ext3, das kann Partitionen größer 2TB ohne Probleme.

Weis jetzt einer ob das mit 3 TB 100% nicht geht? Ich habe eine HS - DHTGL. Geliefert wurde sie mit 1 TB Platten. Die habe ich durch 4, 2 TB Platten getauscht. Kann man diese jetzt ohne Probleme durch 4 , 3 TB Platten tauschen?

Habe es jetzt leider auch feststellen müssen. Die Platten werden mit 2048GB erkannt. Damit ist bei Max 8TB wohl Schluss...

Guten Morgen!!!!

Ich hab diesen Blog gespannt gelesen und hab da mal eine Frage:

Ich habe eine LinkStation LS-1000GL (nach umbau vor 4 Jahren, vorher LS-320GL).

Ist es also möglich die Kiste bis 2tb umzubauen?

Ich hab zwar hier gelesen das es bis 2tb geht aber nicht genau ob auch mit der LS-1000GL?!?!?!

Vielen Dank!!!! 

Ja, man kann eine LS-1000GL mit einer 2TB Platte ausstatten.

Hallo, 

Sagt mir bitte jemand die voreingestellte IP Adresse der Buffalo LS  x2.0tl? 

Ich habe kein dhcp und keinen NAS navigator und finde das passende subnetz nicht :-(

Danke! 

Leder

Habe keine Buffalo mehr im Einsatz, aber das sollte im Handbuch stehen.

Gruß

Guten Tag,

weiß jemand, ob das Buffalo LS-CH System auch eine 4 TB verwalten kann?

Meine 2TB ist schon wieder zu  80% voll.

mfg

Rainer

Hallo

Habe eine Buffalo LS-GL mit 500 GB Festplatte. Habe diese ausgebaut und mit Paragon neu formatiert (NTFS + alle Partitionen und Daten weg) Leider habe ich zuvor keine Sicherung angelegt. Unter Win10 funktioniert diese Platte, aber nicht mehr in der Linkstation (piepst nur noch) Habe leider keine Festplatte zum klonen. LSUpdater findet auch keine Linkstation. Von Tftp habe ich keine Ahnung. Habe Boot Recovery, komme aber damit nicht zurecht. Kann mir jemand weiter helfen? MfG

Kommentar hinzufügen

Der Inhalt dieses Feldes wird nicht öffentlich zugänglich angezeigt.
CAPTCHA
Diese Frage dient dazu festzustellen, ob Sie ein Mensch sind und um automatisierte SPAM-Beiträge zu verhindern.
By submitting this form, you accept the Mollom privacy policy.

Get Firefox!
follow me on twittercounter

 

  • RT : RIP Malcolm Young. Sweet, quiet man. Made all his noise with his guitar. AC/DC night at my house, and loud. Rock an… https://t.co/JYibVJxRl4 vor 12 Stunden 42 Minuten
  • RT : Das beschert mir den Lacher des Morgens. https://t.co/QJBEcl1CSw vor 1 Tag 3 Stunden
  • Kann da keinen Zusammenhang mit 2006 sehen. Diese Schals gab es schon viel früher. Die WM war toll, diese Klientel noch nie. vor 3 Tage 17 Stunden
  • RT : Close to 7 million lines of changed code later and we present the BRAND NEW FIREFOX. Fast, fierce & for good. https://t.co/jNYcP3XFMy vor 4 Tage 15 Stunden
  • RT : Habe ich mich eigentlich schon mal bei dafür bedankt, dass Mensch damit alles gar wundervoll organisi… https://t.co/NYggkzHguE vor 5 Tage 16 Stunden